Stupid question : Unable to drag .png files into Tiled

I’m not sure why it’s not working. The files are just regular .png files. I’m following this tutorial on youtube :

Hope there are any suggestions!


Make sure you drag the images onto the Tilesets view, otherwise Tiled will try to open the files as maps.

Shouldn’t drag & drop be filtered by file extension? Ie ignore .png dropped as TMX and vice versa.

Yeah, this would be a reasonable thing to do. There was also a suggestion recently to automatically create tile objects when images are dragged onto the map, but I guess that goes a little too specific.

1 Like

Thanks i’ve got it working now. Keep up the good work by the way, Tiled is really amazing to work with. Thanks for that.

You’re welcome, @Kairo!

For making the drop handling smarter as @TilemapKit mentioned, I’ve opened the following issue:

I’m having the same problem. I, coincidentally, am following the same tutorial, but when I drag onto Tiled, I get the No Symbol (no smoking sign) icon.

I tried dragging it on to the Tilesets panel, both with an empty tileset (like in the video) as well as with a new, empty “Collection of Images” tileset. But I get the No Symbol no matter what I do.

I’m sure I’m doing something wrong, but I can’t figure it out.

Thanks in advance!

@jason2li Are you sure the image format you’re trying to use is supported by Tiled? And did you remember to make a new map first? Otherwise I would not know what could be the problem there.

Yes, I made sure that I created a new map first, and the images are PNG files. I’m assuming they’re the same ones that Kairo is using, because we’re following the same tutorial.

It’s no big deal really, I just added them one by one instead. Great job with the tool, thanks for all your hard work.

Don’t wanna be the one to necro posts :angel: but I ran into this problem as well and I couldn’t figure out what I was doing wrong… It seems like the very first time you start Tiled and create a new map, dragging and dropping files doesn’t work. It will not accept any files you drag to the window at all (Windows 10, latest released Tiled version as of 2016-03-24).

Restarting Tiled does the trick and now I can’t reproduce the error in any way, not even with new maps.

Hope it helps if you ever attempt to fix it :slight_smile:

@d0tt This thread was never about not being able to drop files at all. It was rather about having to drop files of different types (maps vs. tileset images) in different locations. I’m not aware of the issue you’re describing, and unfortunately don’t think I’ll be able to do anything to fix it if it’s not reproducible.

In the meantime, issue #1031 still stands. I’ve scheduled it for Tiled 1.0 now, since then would be a good time to tackle that.

One suggestions for people who are still having issues with dragging and dropping tilesets, make sure the folder is uncompressed.

Just extract the files first then you should be able to just drag them into Tiled.

I had the same problem and i came here to search a solution and finally solved it alone.
I may be a little dumb… i explain:
i though it was about PNG files but it was just that i forgot to extract my png files from the compressed folder. (Most of the files i had from were compressed)
Every time i tried to drag and drop nothing happened…
and then i extracted all of them
and then Magic
it’s workin’