Tiled 1.1.4 - Tileset panels cannot be repositioned, resets when hover over map


#1

Hello. I used Tiled for some years for personal use. I recently got back into the program but discovered a change that is hard for me to deal with. Tiled no longer remembers when I make the tileset preview window larger than default. I do this by dragging the side of the tileset panel to the left.

In the past the window would stay snapped in this position, which helped because I worked with large tileset images. The problem now is once I move back to edit tiles on my map, the tileset snaps back to the original narrow view.

Here is a picture showing the drag element I’m using to reposition the window.

I have tried resizing the map property window on the left and it shows the same problem. Its position defaults once I hover over the map in the center. A temporary solution I found was to drag the window off the panel so that it becomes a loose, freefloating window. But I would prefer to keep the tileset window as part of the frame element on the right, if possible, instead of a floating window.

How can I rearrange these panels without their position resetting when I hover over the map? Thanks!

edit: A second problem I noticed is that if I undo a map edit with ctrl+z, the render window does not update unless I hover over that tile whose edit I’ve undone.


(Thorbjørn Lindeijer) #2

I have never noticed this problem and you’re the first to report it. It is clearly a bug, but I will need more information to reproduce it because without that I will not know where to look for the problem. What is the version of Tiled you’re seeing this on and on which operating system? Did you try any other versions and did they have the same issue? Do the docks in the tileset editor show the same behavior?

This issue used to happen for new maps, but it’s a bug I fixed in Tiled 1.1.3. If you’re using this version or a later one, I could really use the list of steps to reproduce this issue.


#3

Thanks for the reply!

The window snapping problem seemed to stop when I started up the computer the next day and has not been a problem since.

Occasionally the render window doesn’t update when I use Ctrl+Z but it’s only happened once or twice, whereas on the initial install day, it happened every time. It happened usually when I started a new map, so I wonder if it’s related to the same bug you mention.

I had these problems with Version 1.1.4. I have not tried previous versions recently, but I was using an older version last year that did not have problems. I don’t know its version number but it was before the program’s UI was updated.

If I notice more problems I will try and track their behaviour for you. Thanks for the followup!