My sprites have a blur around them when imported to unity


(Josh D) #1

So when I import my tiled map the sprites aren’t completely together.

Screenshots of what it looks like:



(Seanba) #2

Hi Flamealchamist. I’m guessing what you seeing is seams. First off, check your Console window in Unity for any warning or errors after you export your map. It’s possible that you may have anti-aliasing enabled.

Seams may persist in your Scene view after disabling anti-aliasing but what’s really import is how your map looks in the Game view. If there are no seams there then you’re okay.

However, under some conditions (mostly due to camera location and size) the texture sampler may pick a texel that is just out-of-bounds of your tile. In those cases I put a margin around every tile in my tileset. You can read about that technique here: https://web.archive.org/web/20160313073130/http://www.firebelly.net/post/114529965784/tile-gaps-using-unity-5-and-tiled2unity


(Seanba) #3

Also, this isn’t exactly a Tiled or Tiled2Unity thing but make sure in the texture settings for your texture (rougelikeSheet_transparent) that Filter Mode is set to Point and that no compression is used.