Automapping doesn't work for some reason

Hi everyone,
I’m following a basic shoreline example from the manual, where you place a water tile and have a “shore” tile appear right underneath it.
I have “Automap while Drawing” enabled and I also tried clicking “Automap” manually.

Here is my rule file:

here’s what I have while painting water tiles (nothing…)

(I can’t attach more than three images as a new user, but I’m drawing on a correct layer (named “walls”), and it’s empty.

I’m stuck and perplexed that I can’t reproduce such an easy example.
Any hints would be greatly appreciated, thank you in advance!

here’s the screenshot where automap isn’t doing anything:

and here are the contents of my ‘rules.txt’ file:


By default, a cell that’s empty in all your input layers (and you only have one) means “any other tile”, rather than empty, so your rules aren’t working because they’re looking for something other than empty and other than the base tile you’re using in your rule. Add a bool custom property StrictEmpty to your input_walls layer and set it to true, and that should help. Alternatively, you can add an empty inputnot_walls layer, which will also stop this automatic “any other tile” behaviour from triggering.

You can read more about this behaviour in the Note in the “Definition of inputs” section of the Automapping documentation: Automapping — Tiled 1.8.4 documentation

In the next major Tiled version (1.9), this odd behaviour is going away, you’ll be able to specify that cells are empty tiles and “any other tile” explicitly.

1 Like

Thanks a lot, that solved it. Indeed, that seems like a rather quirky behavior, I’ve seen the documentation section you linked, but the wording there appeared to me to be overly confusing/complex, so I couldn’t grasp the meaning. Looking forward to 1.9 to see this feature streamlined/improved. Thanks again.